Shellshock

Kohteesta Linux.fi
Siirry navigaatioon Siirry hakuun

Shellshock tai Bashdoor (CVE-2014-6271 ja CVE-2014-7169) on haavoittuvuus bash-komentotulkissa. Bugi on ollut olemassa bashin versiosta 1.13 lähtien eli jo vuodesta 1992.

Testaus[muokkaa]

Info.png
Komennot, jotka alkavat merkillä $ (dollari) suoritetaan tavallisena käyttäjänä ja komennot, jotka alkavat merkillä # (ristikkomerkki) suoritetaan pääkäyttäjänä. Katso myös su ja sudo.

CVE-2014-6271[muokkaa]

Mikäli sana "haavoittuva" tulostuu, on bash haavoittuva.

$ env x='() { :;}; echo haavoittuva' bash -c "echo testi"

CVE-2014-7169[muokkaa]

Mikäli päiväys tulostuu, on bash haavoittuva.

$ env X='() { (linux.fi)=>\' bash -c "echo date"; cat echo ; rm -f echo

CVE-???[muokkaa]

Mikäli sana "haavoittuva" tulostuu, on bash haavoittuva.

$ env -i X=' () { }; echo haavoittuva' bash -c 'date'

CVE-2014-7186[muokkaa]

Mikäli sana "haavoittuva" tulostuu, on bash haavoittuva.

$ bash -c 'true <<EOF <<EOF <<EOF <<EOF <<EOF <<EOF <<EOF <<EOF <<EOF <<EOF <<EOF <<EOF <<EOF <<EOF' || echo "CVE-2014-7186 haavoittuva, redir_stack"

CVE-2014-7187[muokkaa]

Mikäli sana "haavoittuva" tulostuu, on bash haavoittuva.

$ (for x in {1..200} ; do echo "for x$x in ; do :"; done; for x in {1..200} ; do echo done ; done) | bash ||
echo "CVE-2014-7187 haavoittuva, word_lineno"

Aiheesta muualla[muokkaa]