KmPlot/Perusohje

Kohteesta Linux.fi
Loikkaa: valikkoon, hakuun

Tässä ohjeessa tutustutaan KmPlot-ohjelmaan, sovelluksen yleisiä toimintoihin sekä käydään läpi kuvaajien piirtäminen. Ohjeen soveltamiseksi suositellaan perustaitoja työpöytäsovellusten käyttämisestä.

Ohjelman perusikkuna[muokkaa]

Seuraavassa on esitelty ohjelman perusikkunan osat:

1-kmplot-matem kuvaaja-perusikkuna.png
  • Ylimpänä on ohjelman työkalurivi, jossa on painikkeet ohjelman tärkeimpiin toimintoihin
  • Ikkunan keskellä on koordinaatisto johon kuvaaja piirretään
  • Alimpana on harmaa tilarivi, jossa näkyy tietoja esimerkiksi koordinaateista liikutettaessa hiirtä koordinaatiston päällä

Työkalurivi[muokkaa]

2-kmplot-matem kuvaaja-tyokalurivi.png
  • Ensimmäiset kolme kuvaketta ovat normaalit tiedostojen käsittelyyn liittyvät toiminnot. Ensimmäisellä aloitetaan uusi kuvaajapohja, toisella avataan tallennettu kuvaaja ja kolmannella tallennetaan nykyinen työ.
  • Neljäs ja viides toiminto liittyvät kuvaajien piirtämiseen. Piirrettävä funktio voidaan syöttää nopeasti työkalurivin tekstikenttään tai yksityskohtaisemmin sen vieressä olevan painikkeen kautta.
  • Viimeisillä kolmella painikkeella hallitaan miltä koordinaatisto näyttää.

Kuvaajan piirtäminen[muokkaa]

Helpoin tapa kuvaajan piirtämiseksi on käyttää pääikkunan tekstikenttää. Tekstikenttään syötetään funktio ja painetaan enter-näppäintä, jolloin ohjelma piirtää kuvaajan. Funktio voidaan kirjoittaa normaalin matemaattisen syntaksin mukaisesti kuten seuraavissa esimerkeissä.

  • x^2 (Huomaa potenssin merkintätapa!)
  • sin x
  • 2 * sin x +5

Tässä esimerkkinä "2 * sin x +5" -funktio piirrettynä KmPlot-ikkunaan

3-kmplot-matem kuvaaja-funktio.png

Kuvaajia on mahdollista piirtää useita peräjälkeen, jolloin ne saavat automaattisesti eri värin kuin edelliset kuvaajat.


Yksityiskohtaisempi kuvaajan piirtäminen[muokkaa]

Kuvaaja on vaihtoehtoisesti mahdollista piirtää valitsemalla Kuvaa > "Uusi funktiokuvaaja...".

4-kmplot-matem kuvaaja-uusi ftio.png

Tällöin avautuu ikkuna johon funktion tiedot voidaan syöttää.

5-kmplot-matem kuvaaja-ftion tiedot.png

Tätä kautta tehtävän kuvaajan ominaisuuksia on mahdollista muokata vapaammin. Seuraavassa on esitelty ikkunassa muokattavissa olevia tietoja.

  • Yhtälö – Piirrettävän funktion kaava
  • Piilota – Piilota funktion kuvaaja näkyvistä. Funktiota voidaan silti käyttää määriteltäessä toisia funkioita
  • Oma kuvaajan arvoväli - Min – Määrittää kuinka pieniä arvoja funktio voi pienimmillään saada
  • Oma kuvaajan arvoväli - Max - Määrittää kuinka suuria arvoja funktio voi enintään saada
  • Viivan leveys – Kuvaajan viivan paksuus millin kymmenesosina
  • Väri – Kuvaajan väri

Valmis kuvaaja hyväksytään napsauttamalla OK-painiketta, jolloin sen kuvaaja piirretään.

Valmiin kuvaajan muokkaaminen[muokkaa]

Valmiita kuvaajia voidaan muokata vapaasti seuraavalla tavalla.

  • Valitse Kuvaa > Muokkaa kuvaajia...
  • Valitse avautuvasta ikkunasta muokattava funktio
6-kmplot-matem kuvaaja-ftion muokk.png
  • Napsauta Muokkaa-painiketta

Tämän jälkeen avautuu ikkuna josta valitun funtion asetuksia voidaan muokata. Ikkunan kentät vastaavat täysin edellisessä kappaleessa esiteltyä uuden kuvaajan luomista. Muokkaukset hyväksytään napsauttamalla OK-painiketta


Matemaattisissa funktioissa esiintyy yleensä neliöjuuria ja potenssiin korotuksia, joiden kirjoittaminen tietokoneen näppäimistöllä ei ole itsestäänselvyys. Tässä artikkelissa tutustutaan miten erilaisten funktioiden ja vakioiden syöttäminen onnistuu KmPlotissa.

Funktioden kirjoittaminen[muokkaa]

Seuraavassa on esitelty erilaisia tyypillisiä matemaattisissa lausekkeissa vastaan tulevia funktioita, merkkejä sekä vakioita. Tietokoneen näppäimistöltä ei suoraan löydy näppäimiä esimerkiksi neliöjuurilausekkeen syöttämiseen, mutta tässä artikkelissa tutustutaan miten se KmPlotissa on mahdollista. Kyseisiä funktioita voidaan käyttää piirrettäessä kuvaajia KmPlot ohjelmalla.

Potenssiin korottaminen[muokkaa]

^ - Esimerkiksi x korotettuna neljänteen potenssiin syötettäisiin seuraavasti x^4.

Peruslaskutoimitukset ja vertailu[muokkaa]

*, /, +, , <, > , = - Peruslaskutoimitusfunktiot ja suuruuden vertailuun käytettävät merkit, toimivat normaalisti näppäimistöltä syötettäessä.

Itseisarvo[muokkaa]

|x| - Itseisarvo voidaan ilmaista edellä olevalla tavalla jättämällä luku niin sanottujen putkimerkkien väliin. Tämä merkki löytyy normaaleista näppäimistöistä suoraan.

Neliöjuuri[muokkaa]

sqrt(x) - Normaali neliöjuuri ilmaistaan sqrt funktiolla. Esimerkiksi neliöjuuri luvustayhdeksän kirjoitettaisiin seuraavasti sqrt(9).

Luonnollinen logaritmi[muokkaa]

ln(x) - Luonnollinen logaritmi ilmaistaan funktiolla ln. Esimerkiksi luonnollinen logaritmi luvusta kahdeksan kirjoitettaisiin ln(8).

Kymmenkantainen logaritmi[muokkaa]

log(x) - Kymmenkantainen logaritmi ilmaistaan funktiolla log. Esimerkiksi kymmenkantainen logaritmi luvusta 4 kirjoitettaisiin log(4).

Trigonometristen funktioiden kirjoittaminen[muokkaa]

Oletusasetuksilla KPlot käyttää radiaani yksiköitä. Ohjelma voidaan asettaa käyttämään yksikkönä asteita seuraavasti.
1-kmplot-matem syntaksi-muokkaa.png
  • Valitse Asetukset > Aseta KmPlot
  • Aktivoi avautuneesta ikkunasta valinta asteet
  • Napsauta OK

Sini, kosini ja tangentti[muokkaa]

sin(x), cos(x), tan(x) - Sini, kosini ja tangentti funktiot syötetään edellä mainituilla funktiolyhenteillä. Esimerkiksi sinin kuvaaja muuttujalla x piirrettäisiin kirjoittamalla sin(x). Samoin toimivat edellisten käänteisfunktiot arcsin(x), arccos(x), arctan(x)

Kotangentti, sekantti ja kosekantti[muokkaa]

cot(x), sec(x), cosec(x) - Kotangentti, sekantti ja kosekantti toimivat samalla tavoin kuin edelliset sini-, kosini- ja tangenttifunktiot. Samoin myös käänteisfunktioiden kohdalla jotka ovat arccot(x), arcsec(x), arccosec(x)

Matemaattisten vakioiden kirjoittaminen[muokkaa]

Pii[muokkaa]

pi - Pii-vakiota (3.1415...) voidaan käyttää joko syöttämällä edellä mainittu pi-merkintä tai käyttämällä sen likiarvoa.

Neperin luku[muokkaa]

e - Neperin luku (2.7182...) voidaan syöttää joko käyttämällä edellämainittua e-symbolia tai vaihtoehtoisesti likiarvoa käyttäen.


Derivaatta- ja integraalifunktion kuvaajien piirtäminen[muokkaa]

Derivaatta- ja integraalifunktion kuvaajat piirretään halutulle funktiolle sen muokkaustilassa.

  • Valitse Kuvaa > Muokkaa kuvaajia...
  • Valitse funktio, jonka derivaatta- tai integraalifunktio halutaan piirtää ja napsauta muokkaa.
1-kmplot-integr deriv-funktion valinta.png
  • Jos funktiota ei vielä ole, luo uusi funktio napsauttamalla Uusi funktiokuvaaja... ja syötä funktio avautuvaan ikkunaan.

Derivaattafunktion kuvaajan tekeminen[muokkaa]

Valitse funktion muokkausikkunan vasemmasta reunasta Derivaatat -kuvake.

2-kmplot-integr deriv-derivaatat.png

Kyseisen kuvaajan ensimmäinen ja toinen derivatta saadaan näkyviin valitsemalla Näytä 1./(2.) derivaatta ja napsauttamalla OK-painiketta. Alla on esimerkkikuva funktiosta (punainen) ja sen ensimmäisestä derivaatasta (vihreä).

3-kmplot-integr deriv-derivaattakuva.png

Integraalifunktion kuvaajan tekeminen[muokkaa]

Valitse funktion muokkausikkunan vasemmasta reunasta Integraali -kuvake.

4-kmplot-integr deriv-integraalit.png

Napsauta Näytä Integraali -painiketta, jonka jälkeen integraalifunktio tulee näkyviin. Sen kuvaajan väriä ja muita asetuksia voidaan muuttaa ikkunassa olevista asetuksista.

Kuvaajan arvojen tutkiminen[muokkaa]

Kuvaajista voidaan selvittää esimerkiksi funktion arvo sekä graafisesti että laskennallisesti ja lisäksi funktion minimi- ja maksimiarvot tietyllä arvovälillä.

Funktion arvojen tutkiminen graafisesti[muokkaa]

Funktion arvoja voidaan tutkia graafisesti, napsauttamalla valmiiksi piirrettyä kuvaajaa ohjelman perustilassa.

5-kmplot-integr deriv-graafiset arvot.png

Tällöin kursori tarttuu kuvaajaan kiinni ja liikuttamalla hiirtä sivuttaissuunnassa nähdään funktion arvot muuttujan suhteen ikkunan alareunasta. Funktion nollakohdat näkyvät erikseen niitä lähestyttäessä.

Funktion arvon selvittäminen laskennallisesti[muokkaa]

Funktion arvoja voidaan selvittää tarkasti laskemalla seuraavasti.

  • Valitse Työkalut > Laske y-arvo
  • Valitse avautuvan ikkunan alaosasta tutkittava funktio
  • Syötä ikkunan yläosan X-tekstikenttään muuttujan arvo jota vastaava funktion arvo halutaan selvittää ja napsauta Laske.
    6-kmplot-integr deriv-arvon laskeminen.png

Maksimi- ja minimiarvojen tutkiminen[muokkaa]

Funktion maksimi- tai minimiarvo voidaan selvittää seuraavasti.

  • Valitse Työkalut > Etsi minimiarvoa/maksimiarvoa... riippuen siitä kumpaa halutaan tutkia
  • Valitse avautuvan ikkunan alaosasta tutkittava funktio
  • Aseta raja muuttujan arvoille minimistä maksimiin ikkunan yläosassa oleviin tekstikenttiin, jotta ohjelma tietää miltä väliltä arvoa halutaan selvittää.
7-kmplot-integr deriv-max min.png
  • Napsauta Etsi, jolloin ohjelma kertoo halutun arvon suuruuden ja sen paikan.

Kuvaajan tallentaminen erilliseen kuvatiedostoon[muokkaa]

KmPlotilla piirrettävät kuvaajat on mahdollista tallentaa erilliseen kuvatiedostoon. Tällöin itse piirrettyjä kuvaajia voidaan liittää esimerkiksi omaan tekstinkäsittelydokumenttiin. Piirretyn kuvaajan tallentaminen tapahtuu seuraavasti.

  • Valitse Tiedosto > Vie...
  • Anna avautuvaan ikkunaan tallennettavalle kuvalle nimi
  • Valitse kuva tiedostotyyppi. Normaaliin käyttöön paras on PNG-muoto.
8-kmplot-integr deriv-tallenna.png
  • Napsauta Tallenna-painiketta

Katso myös[muokkaa]