Inkscapen peruskäyttö

Kohteesta Linux.fi
Loikkaa: valikkoon, hakuun

Inkscape on avoimen lähdekoodin ohjelma vektorigrafiikan piirtämiseen. Se sopii hyvin esimerkiksi logojen, nettigrafiikan tai teknisten kaavioiden piirtämiseen. Tämä ohje käsittelee Inscapen käyttöä ja perusominaisuuksia ohjeessa piirrettävän mallikuvan avulla.

Yleistä[muokkaa]

Inkscapen käytössä pätee ajattelutapa, jossa tavallisen työpöydän päälle asetetaan paperista tai läpinäkyvästä kalvosta leikattuja kuvioita ja sijoitella niitä pohjapaperille tiettyyn järjestykseen. Kuvioiden fyysinen luonne ei kuitenkaan ole kuin paperilla, vaan niiden kokoa, muotoa ja väriä voidaan loputtomasti muokata. Inkscapen vastakohtana voidaan pitää ns. bittikarttapiirto-ohjelmia kuten Gimp, joissa käsitellään tiettyjen muokattavien kohteiden ja muotojen sijasta yksittäisiä kuvapisteitä. Inkscape ei siis sovellu Gimpin tapaan esimerkiksi valokuvien muokkaamiseen ja käsittelyyn.

Perustoiminnot[muokkaa]

Avautuessaan Inkscapen työtila näyttää seuraavalta:

1-Inkscape-perusikkuna.png

Ikkunaruutu koostuu työtilasta ja sitä ympäröivistä tehtäväpalkeista, joita ovat:

  • Komentorivi - Sisältää pikanäppäimet tiedostojen käsittelyyn sekä yleisimpiin objektien käsittelyä koskeviin toimintoihin, kuten objektin värien, fonttien ym. muokkaamiseen.
  • Ominaisuusrivi - Sisältää työkalukohtaisia toimintoja esimerkiksi objektin peilaamiseen ja kääntämiseen.
  • Työkalurivi - Työkalut objektien piirtämiseen, asetteluun ja muokkaamiseen.

Zoomaus ja ikkunan vieritys[muokkaa]

Perustyökalu zoomaukseen löytyy työkalupalkissa olevasta suurennuslasista. Oletuksena suurennuslasi zoomaa lähemmäksi ja painamalla käytettäessä Shift-näppäin pohjaan loitommaksi. Nopeampia zoomauskeinoja ovat:

  • Ctrl-näppäimen painaminen pohjaan ja hiiren rullan pyörittäminen
  • Näppäimistön '+- ja -näppäimien painaminen

Ikkunan vieritys onnistuu perinteisesti ikkunan vierityspalkeista. Lisäksi on mahdollista käyttää hiiren rullaa pystysuoraan vieritykseen ja Shift-näppäintä pohjassa painaen vaakasuoraan vieritykseen. Kuvaa voi vierittää ylös ja alas suoraan hiiren rullasta. Painamalla näppäintä ⇧ Shift ja vierittämällä hiiren rullaa ylös tai alas. Kuva vierittyy sivusuunnassa.

Kuvioiden piirtäminen ja muokkaus[muokkaa]

Kuvioiden piirtäminen[muokkaa]

Valitse työkalupalkista suorakulmio ja kokeile piirtää hiiren avulla työtilaan mallin mukainen kuvio. Piirtäminen tapahtuu painamalla hiiren näppäin pohjaan ja liikuttamalla hiirtä, jolloin suorakulmion koko alkaa hahmottua.

2-Inkscape-suorakulmio.png

Kokeile piirtää myös muita kuvioita kuten ympyrää, tähteä ja spiraalia.

3-Inkscape-kuvioita.png

Piirretyt kuviot ovat täysin itsenäisiä hallittavissa piirtämisen jälkeenkin. Piirrettäessä kuvioiden reunoihin ilmestyvät pienet nuolet, joista vetämällä kuvion muoto muuttuu.

4-Inkscape-muodon-saataminen.png

Viivojen piirtämiseen on useita eri työkaluja. Tavallisen viivan piirtäminen onnistuu parhaiten työkalupalkista löytyvällä ”Piirrä viivoja käsivaraisesti” (Draw freehand) -toiminnolla. Sillä voi piirtää ns. vapaalla kädellä sekä tehdä helposti myös suoria viivoja. Suoran viivan piirtäminen onnistuu seuraavasti:

  • Valitse ”Piirrä viivoja käsivaraisesti” (Draw freehand)-toiminto.
  • Napsauta kohtaa josta viiva alkaa
  • Napsauta kohtaa johon viiva päättyy

Viivoihin pätevät samat toiminnot ja ominaisuudet kuin muihinkin kuvioihin.

Kuvioiden muokkaus[muokkaa]

Kuvioiden valitsemista ja muokkausta varten käytettävissä on oma työkalu, joka löytyy työkalupalkista ylimpänä olevasta nuolen kuvasta tai painamalla näppäintä F1. Tällä työkalulla voidaan valita useampia kuvioita yhtäaikaisesti, muuttaa kuvioiden kokoa ja pyörittää niitä haluttuun asentoon.

Kuvioiden värit[muokkaa]

Kuviot koostuvat pääasiallisesti kahdesta osasta, rajaviivasta (stroke) ja täytteestä (fill). Molemmille voidaan määrittää väri, läpinäkyvyys paksuus tai ottaa ne kokonaan pois. Kuvion värejä muokataan napsauttamalla kuviota hiiren kakkospainikkeella ja valitsemalla ”Täyttö ja viiva” (Fill and Stroke). Seuraavaksi tehdään suorakulmiosta tummanpunainen väriliuku ilman rajaviivaa:

  • Valitse valintatyökalu eli nuoli työkalupalkista.
  • Napsauta ympyrää hiiren kakkospainikkeella ja valitse Täyttö ja viiva (Fill and Stroke).
  • Aseta avautuneesta ikkunasta Täyttö (Fill)-välilehdeltä suora liukuväri (linear-gradient) päälle.

5-Inkscape-taytto ja reuna1.png

  • Alla olevasta ruudullisesta alueesta voidaan muuttaa väriliu'un suuntaa ja voimakkuutta. Peittävyys (Master opacity) -kohdasta säädetään koko kuvion läpinäkyvyyttä.
  • Siirry välilehdelle Viivan väritys (Stroke paint) ja napsauta se pois käytöstä painamalla x-kuviota.
  • Sulje ikkuna

Kuvion pitäisi nyt näyttää seuraavalta:

6-Inkscape-taytto ja reuna2.png

Kuvion koko ja kääntäminen[muokkaa]

Kuvion kokoa muutetaan napsauttamalla kuviota valintatyökalulla. Tällöin kuvion ympärille ilmestyy nuolet, joista kuvion kokoa voidaan muuttaa vetämällä.

7-Inkscape-kuvion koko.png

Jos haluaa säilyttää kuva suhteen kokoa muutettaessa se onnistuu pitämällä CTRL-näppäintä pohjassa samalla kun vetää nuolista.

Kuvion kääntäminen onnistuu napsauttamalla kuviota toistamiseen, jolloin ympärillä olevat nuolet vaihtavat suuntaansa ja keskelle kuviota ilmestyy pyörimisen keskiakseli.

8-Inkscape-kuvion kaanto.png

Kuviota voidaan nyt pyörittää vetämällä kulmanuolista haluttuihin suuntiin tai taivuttaa keskinuolista. Pyöriminen tapahtuu kuvion keskellä olevan raksin suhteen, jonka paikkaa voidaan vapaasti muuttaa sitä raahaamalla. Kuvion pyörittämisessä kätevänä apuna toimii jälleen CTRL-näppäin, joka pyöritettäessä pohjaan painettuna kääntää kuviota 15 asteen kulmissa. Seuraavaksi käännetään sininen suorakulmio ja kasvatetaan sen kokoa.

  • Valitse suorakulmio kuvionmuokkaustyökalulla.
  • Napsauta kuviota toistamiseen, niin että kuviota voidaan pyörittää.
  • Paina 'CTRL-näppäin pohjaan ja pyöritä kuviota, niin että tumma osa tulee ylöspäin.

9-Inkscape-kuviot ikkunassa.png

  • Napsauta kuviota uudestaan ja venytä se suuremmaksi, esimerkiksi koko sivualueen kokoiseksi.

10-Inkscape-kuviot pohjalla.png

Kuvion tason muokkaaminen[muokkaa]

Kuviot sijaitsevat omilla tasoillaan, joka tarkoittaa sitä, että ne voivat olla toistensa päällä ja alla aivan kuten esimerkiksi paperinpalat pöydällä. Kuvion tasoa voidaan muuttaa napsauttamalla kuvio aktiiviseksi ja valitsemalla Kohde (Object) > Nosta (Raise) tai Laske (Lower). Tason muuttaminen onnistuu myös työkalujen hallintapalkissa olevilla kuvakkeilla. Kokeile esimerkiksi taustana olevan sinisen suorakulmion tuomista muiden kuvioiden eteen ja sen jälkeen sen viemistä taaimmaksi.

  • Valitse sininen suorakulmio.
  • Valitse Kohde (Object) > Tuo päälimmäiseksi... (Raise to Top)

Nyt suorakulmio on kaikkien muiden kuvioiden yläpuolella. Kuviot näkyvät yhä alta koska suorakulmion värit on määritetty osittain läpinäkyväksi. Tilannetta voi verrata esimerkiksi piirtoheitinkalvojen päällekkäisyyteen. Asetetaan suorakulmio takaisin alimmaksi.Valitse Kohde (Object) > Vie alimmaiseksi... (Lower to Bottom)

12-Inkscape-kuviot eri tasoilla.png

Monen kuvion samanaikainen valitseminen[muokkaa]

Tarvittaessa on mahdollista siirtää useita kuvioita samanaikaisesti. Tämä onnistuu painamalla ⇧ Shift-näppäin pohjaan ja valitsemalla hiirellä samanaikaisesti halutut kuviot. Monta kuviota voidaan myös valita rajaamalla hiiren avulla alue jonka sisällä olevat kuviot halutaan valita. Tämä onnistuu valitsemalla muokkaustyökalu ja vetämällä hiirtä näppäin pohjassa halutulta alueelta.

Kuvioiden ryhmittäminen[muokkaa]

Pelkän usean kuvion valitsemisen lisäksi erillisistä kuvioista voidaan tehdä ryhmiä, jolloin valitut kuviot käyttäytyvät kuin ne olisivat vain yksi ja sama kuvio. Tämä onnistuu valitsemalla edellisen kappaleen mukaisesti halutut kuviot ja valitsemalla Kohde (Object) -> Ryhmitä (Group). Ryhmityksen purkaminen onnistuu valitsemalla haluttu kuvioryhmä ja valitsemalla Kohde (Object) -> Pura ryhmitys (Ungroup). Tai valitsemalla halutut kohteet. Oikean puoleisella näppäimellä valitse Ryhmitä. Ryhmittäminen onnistuu vaikka kuviot olisivat eri tasoilla.

Kuvion monistaminen[muokkaa]

Tiettyä kuviota voidaan ”monistaa” tutun leikkaa – liimaa periaatteen mukaisesti.

  • Valitse monistettava kuvio
  • Valitse Muokkaa (Edit) > Kopioi (Copy) tai paina CTRL·c
  • Valitsemalla Muokkaa (Edit) > Liitä (Paste) tai painamalla CTRL·v, kuvio kopioituu kohtaan johon hiiren kursori osoittaa.

Toimintojen kokeilu ja mallikuvan viimeistely.[muokkaa]

Lopuksi kokeilemme muutamia toimintoja eri käytännöissä ja viimeistelemme mallikuvaa näyttämään yksinkertaiselta aamutaivaalta. Aluksi tehdään maastoa kuvan alareunaan, käyttäen Piirrä suoria ja Bezier-viivoja (Draw bezier curves)-työkalua.

  • Valitse Piirrä suoria ja Bezier-viivoja -työkalu. Voit valita Bezier-viivatyökalun painamalla näppäimiä ⇧ Shift·F6.
  • Piirrä hiirellä napsutellen ensin maaston yläosa vasemmalta oikealle. Oikeassa reunassa vedä suora viiva reunaa myöten alas ja jatka samalla tavalla alareunassa ja vasemmalla sivustalla.
  • Lopulta kun viivat kohtaavat alku- ja loppupisteessä napsauta hiiren kakkospainiketta.
  • Aktivoi uusi kuvio jossa tällä hetkellä on pelkät ääriviivat.
  • Napsauta kuviota hiiren kakkospainikkeella ja valitse Täyttö ja rajaviiva (Fill and Stroke).
  • Valitse Tasainen väri (Flat Color) asetuksista väriksi tumman vihreä.
  • Aseta Suora väriliuku (Linear Gradient) valikon asetukset seuraavan kuvan tavalla.
  • Maaston tulisi olla vihreä.


11-Inkscape-valmis kuva.png

Lopuksi taivaan väri voidaan laittaa siniseksi väriliuksi, sekä taivaalla olevaa spiraalia voi monistaa leikkaa ja liimaa -tekniikalla, sekä muuttaa spiraalit eri kokoisiksi pilviksi. Ympyrästä väri voidaan muuttaa keltaiseksi ja asettaa se auringoksi yläreunaan. Tähden voi joko poistaa tai häivyttää se horisonttiin.

Kuvan tallentaminen bittikarttana[muokkaa]

2-inkscape-siirto-tallenna-bittikartta.png

Inkscape -piirto-ohjelma tallentaan normaalisti tiedostonsa ns. vektorigrafiikkamuodossa, joita ei pysty avaamaan suoraan normaaleissa kuvankäsittelyohjelmissa. Kuvat voidaan kuitenkin "viedä" myös ns. bittikarttamuotoon. Tässä ohjeessa tutustutaan miten Inkscapella piirrettyjä kuvia voidaan tallentaa ns. "normaalissa" (bittikartta)-kuvamuodossa, jolloin ne voidaan avata esimerkiksi Gimp -kuvankäsittelyohjelmassa valokuvatiedostojen tapaan.

Tallentaminen png-muotoon[muokkaa]

Seuraavassa tallennetaan esimerkkikuva png-tiedostoksi.

  • Valitse tallennettava kuva/kuva-alue napsauttamalla kuvaa tai maalaamalla hiiren avulla alue jonka alla tallennettavat kuvat ovat.

3-inkscape-siirto-tallenna-bittikartta-tiedosto.png

  • Valitse Tiedosto > Export PNG image ⇧ Shift·CTRL·E

Avautuneeseen ikkunaan syötetään kuvan tallentamiseen tarvittavat tiedot ja asetukset.

  • Tallenna alue - Valitaan tallennetaanko kuvaksi koko sivu, jokin piirros, itse valittu osa vai itse määritetty alue
  • Bittikartan koko -Määritetään tulevan tallennettavan kuvan "fyysinen koko" pisteinä leveys ja korkeus suunnissa tai dpi-lukuna (pistettä tuumaa kohden). Tämä valinta vaikuttaa oleellisesti luotavan tiedoston kokoon ja laatuun.
  • Tiedostonimi - Syötetään tallennettavalle tiedostolle tallennuspolku ja sitä kuvaava nimi .png -tiedostopäätteellä.

Lopullinen kuvan tallentaminen tapahtuu napsauttamalla Vie- painiketta jolloin kuva tallentuu kohdekansioon.