GCC 4.1 Gentoossa

Kohteesta Linux.fi
Loikkaa: valikkoon, hakuun
Tiimalasi.png
Artikkelin sisältö on osittain vanhentunut. Voit auttaa Linux.fi-wikiä päivittämällä artikkelin ajan tasalle.

Tämä ohje kertoo, kuinka Gentoon saa käyttämään GCC:n versiota 4.1. Asennuksen jälkeen järjestelmä on joissain tapauksissa käännettävä uudestaan, jotta ohjelmat linkitettäisiin uuden kääntäjän kirjastoja vastaan.

Kaikki ohjelmat eivät toistaiseksi käänny GCC:n uusilla versioilla.

GCC:n asentaminen ja järjestelmän päivittäminen[muokkaa]

GCC:n asentaminen[muokkaa]

emerge -av gcc

GCC:n ottaminen käyttöön[muokkaa]

Vaihdetaan kääntäjä

#Ensiksi katsotaan mitkä versiot ovat asennettuna
gcc-config -l
#Sitten otetaan käyttöön GCC 4.1.1
gcc-config i686-pc-linux-gnu-4.1.1
source /etc/profile
#Lopuksi vielä käännetään libtools uudella kääntäjällä
emerge --oneshot -av libtool

Tämän jälkeen asennetaan libstdc++, jotta voidaan ajaa vanhempaan kääntäjään linkitettyjä ohjelmia

emerge --oneshot sys-libs/libstdc++-v3

Jos käytät ccachea, on se tyhjennettävä:

CCACHE_DIR="/var/tmp/ccache" ccache -C

Järjestelmän uudelleenkääntäminen[muokkaa]

Jos vanha kääntäjäsi oli vanhempi kuin gcc-4.0, sinun on nyt käännettävä järjestelmä uudelleen.

emerge -eav world

Mikäli käännöstyö jossain vaiheessa katkeaa, voit jatkaa sitä seuraavalla komennolla

emerge --resume

Voit myös jättää yhden käännöksen välistä komennolla

emerge --resume --skipfirst

Vanhan kääntäjän poistaminen[muokkaa]

Lopuksi poistetaan vanha kääntäjä

emerge -aC =sys-devel/gcc-<versio>

Esimerkiksi GCC 3.3:n poistaminen tapahtuu seuraavasti:

emerge -aC =sys-devel/gcc-3.3*

Paketteja, jotka eivät käänny gcc-4.1:llä[muokkaa]