Ero sivun ”LAMP” versioiden välillä

Kohteesta Linux.fi
Siirry navigaatioon Siirry hakuun
Rivi 17: Rivi 17:
  
 
# Asenna Ubuntu 10.04 LTS (hyvin suosittu ja helppokäyttöinen Linux, ja sen pitkäaikaisen tuen versio, jonka palvelinohjelmistoille on taattu tietoturvapäivitykset vuoteen 2015 saakka)
 
# Asenna Ubuntu 10.04 LTS (hyvin suosittu ja helppokäyttöinen Linux, ja sen pitkäaikaisen tuen versio, jonka palvelinohjelmistoille on taattu tietoturvapäivitykset vuoteen 2015 saakka)
# Avaa pääte ja aja ''sudo apt-get install php5-mysql mysql-server'', mikä asentaa em. ohjelmat ja kaikki niiden riippuvuudet, mukaan lukien Apache-palvelimen:
+
# Avaa pääte ja aja ''sudo apt-get install php5 php5-mysql mysql-server'', mikä asentaa em. ohjelmat ja kaikki niiden riippuvuudet, mukaan lukien Apache-palvelimen:
  
  $ sudo apt-get install php5-mysql mysql-server
+
  $ sudo apt-get install php5 php5-mysql mysql-server
 
  Luetaan pakettiluetteloita... Valmis
 
  Luetaan pakettiluetteloita... Valmis
 
  Muodostetaan riippuvuussuhteiden puu       
 
  Muodostetaan riippuvuussuhteiden puu       
 
  Luetaan tilatiedot... Valmis         
 
  Luetaan tilatiedot... Valmis         
 
  Seuraavat ylimääräiset paketit on merkitty asennettaviksi:
 
  Seuraavat ylimääräiset paketit on merkitty asennettaviksi:
apache2-mpm-prefork apache2-utils apache2.2-bin apache2.2-common
+
  apache2-mpm-prefork apache2-utils apache2.2-bin apache2.2-common
libapache2-mod-php5 libapr1 libaprutil1 libaprutil1-dbd-sqlite3
+
  libapache2-mod-php5 libapr1 libaprutil1 libaprutil1-dbd-sqlite3
libaprutil1-ldap libdbd-mysql-perl libdbi-perl libhtml-template-perl
+
  libaprutil1-ldap libdbd-mysql-perl libdbi-perl libhtml-template-perl
libmysqlclient16 libnet-daemon-perl libplrpc-perl mysql-client-5.1
+
  libmysqlclient16 libnet-daemon-perl libplrpc-perl mysql-client-5.1
mysql-client-core-5.1 mysql-common mysql-server-5.1 mysql-server-core-5.1
+
  mysql-client-core-5.1 mysql-common mysql-server-5.1 mysql-server-core-5.1
php5-common
+
  php5-common
 
  Ehdotetut paketit:
 
  Ehdotetut paketit:
apache2-doc apache2-suexec apache2-suexec-custom php-pear dbishell
+
  apache2-doc apache2-suexec apache2-suexec-custom php-pear dbishell
libipc-sharedcache-perl tinyca mailx php5-suhosin
+
  libipc-sharedcache-perl tinyca mailx php5-suhosin
 
  Seuraavat UUDET paketit asennetaan:
 
  Seuraavat UUDET paketit asennetaan:
apache2-mpm-prefork apache2-utils apache2.2-bin apache2.2-common
+
  apache2-mpm-prefork apache2-utils apache2.2-bin apache2.2-common
libapache2-mod-php5 libapr1 libaprutil1 libaprutil1-dbd-sqlite3
+
  libapache2-mod-php5 libapr1 libaprutil1 libaprutil1-dbd-sqlite3
libaprutil1-ldap libdbd-mysql-perl libdbi-perl libhtml-template-perl
+
  libaprutil1-ldap libdbd-mysql-perl libdbi-perl libhtml-template-perl
libmysqlclient16 libnet-daemon-perl libplrpc-perl mysql-client-5.1
+
  libmysqlclient16 libnet-daemon-perl libplrpc-perl mysql-client-5.1
mysql-client-core-5.1 mysql-common mysql-server mysql-server-5.1
+
  mysql-client-core-5.1 mysql-common mysql-server mysql-server-5.1
mysql-server-core-5.1 php5-common php5-mysql
+
  mysql-server-core-5.1 php5 php5-common php5-mysql
 
  0 päivitetty, 23 uutta asennusta, 0 poistettavaa ja 3 päivittämätöntä.
 
  0 päivitetty, 23 uutta asennusta, 0 poistettavaa ja 3 päivittämätöntä.
 
  Noudettavaa arkistoa 30,0Mt.
 
  Noudettavaa arkistoa 30,0Mt.
Rivi 45: Rivi 45:
 
  Haluatko jatkaa [K/e]?
 
  Haluatko jatkaa [K/e]?
  
#<li value="3"> Käynnistä Apache komennolla ''sudo /etc/init.d/apache2 start''
+
#<li value="3"> Asennusvaiheessa pyydetään asettamaan MySQL:n pääkäyttäjälle (root) salasana. Laita se muistiin.
 
# Tarkista Apachen toimivuus selaimella (http://127.0.0.1/ tai http://localhost/)
 
# Tarkista Apachen toimivuus selaimella (http://127.0.0.1/ tai http://localhost/)
# Nyt voit laittaa PHP-skriptin kansioon /var/www/htdocs/ ja tehdä mitä haluat
+
# Nyt voit laittaa PHP-skriptin kansioon /var/www/. Aja komento ''sudo nano /var/www/testi.php'' ja kirjoita tiedoston sisällöksi:
#* Tai kokeile vaikka asentaa valmis PHP-ohjelmisto, kuten Wordpress-blogiohjelmisto komennolla ''sudo apt-get install wordpress''
+
<?php
 +
echo "Testi toimii!";
 +
?>
 +
#<li value="6"> Tallenna painamalla Ctrl+X ja enter (K=kyllä)
 +
# Avaa selaimella http://localhost/testi.php. Jos näet vain tekstin, niin PHP toimii. Jos selain yrittää ladata kokonaisena tiedostona sivun, PHP-skriptiä ei ajettu.
 +
 
 +
=== Wordpress ===
 +
 
 +
Lisäharjoituksena voit asentaa Wordpressin, joka on PHP:lla ja MySQL:llä toimiva blogiohjelmisto. Aloita komennolla ''sudo apt-get install wordpress''
 +
 
 +
$ sudo apt-get install wordpress
 +
Luetaan pakettiluetteloita... Valmis
 +
Muodostetaan riippuvuussuhteiden puu     
 +
Luetaan tilatiedot... Valmis       
 +
Seuraavat ylimääräiset paketit on merkitty asennettaviksi:
 +
  javascript-common libjs-cropper libjs-prototype libjs-scriptaculous
 +
  libphp-phpmailer libphp-snoopy libt1-5 php-gettext php5-gd tinymce
 +
  wordpress-l10n wwwconfig-common
 +
Ehdotetut paketit:
 +
  mail-transport-agent curl postgresql-client apache apache-ssl
 +
Seuraavat UUDET paketit asennetaan:
 +
  javascript-common libjs-cropper libjs-prototype libjs-scriptaculous
 +
  libphp-phpmailer libphp-snoopy libt1-5 php-gettext php5-gd tinymce wordpress
 +
  wordpress-l10n wwwconfig-common
 +
0 päivitetty, 13 uutta asennusta, 0 poistettavaa ja 3 päivittämätöntä.
 +
Noudettavaa arkistoa 8 107kt.
 +
Toiminnon jälkeen käytetään 30,4M t lisää levytilaa.
 +
Haluatko jatkaa [K/e]?
  
  
Rivi 54: Rivi 81:
  
 
LAMP ei tänä päivänä enää edusta parasta mahdollista teknologiaa. Apachen kanssa kilpailee moni uusi paljon nopeampi palvelinohjelmisto (esim. NodeJS ja Nginx), Oracleen haltuun siirtynyt MySQL häviää MariaDB:lle ja PostgreSQL:lle ja ohjelmointikielipuolella on nykyisin suositumpaa käyttää JavaEE:tä, Ruby on Railisia tai Pythonia (esim. [http://www.djangoproject.com/ Djangon] kanssa).
 
LAMP ei tänä päivänä enää edusta parasta mahdollista teknologiaa. Apachen kanssa kilpailee moni uusi paljon nopeampi palvelinohjelmisto (esim. NodeJS ja Nginx), Oracleen haltuun siirtynyt MySQL häviää MariaDB:lle ja PostgreSQL:lle ja ohjelmointikielipuolella on nykyisin suositumpaa käyttää JavaEE:tä, Ruby on Railisia tai Pythonia (esim. [http://www.djangoproject.com/ Djangon] kanssa).
 
  
 
==Katso myös==
 
==Katso myös==

Versio 25. elokuuta 2011 kello 16.02


Lyhenne LAMP tarkoittaa:

Lyhennettä käytetään kuvaamaan erittäin yleistä web-palvelinteknologian kokoonpanoa, jossa palvelinkoneen käyttöjärjestelmänä on Linux, palvelinohjelmistona Apache, tietokantaohjelmistona on MySQL ja dynaamisuuden ja vuorovaikutteisuuden mahdollistavana palvelinpuolen skriptikielenä tyypillisimmin PHP. LAMP on saatavilla kutakuinkin jokaisesta palvelinhotellipaketista, sillä on mahdollista toteuttaa huomattavan mutkikkaita ja monipuolisia verkkopalveluja (esim. Facebook tehtiin LAMP:lla alussa) ja se onkin ollut pitkään hyvin suosittu.

On syytä huomata, että kyseessä on ainoastaan selventävä termi, eikä vaikkapa ohjelmien välinen yhteyskäytäntö. Yhdistelmälle on annettu nimi, koska sitä käytetään melko paljon ja se on havaittu toimivaksi. Samalla idealla on kehitetty muitakin lyhenteitä kuten Solaris-pohjainen SAMP ja Windows/IIS-yhdistelmään pohjautuva WIMP.

LAMP-ympäristön asennus omalle koneelle

Seuraavassa lyhyt yhteenveto miten LAMPin voi pystyttää.

  1. Asenna Ubuntu 10.04 LTS (hyvin suosittu ja helppokäyttöinen Linux, ja sen pitkäaikaisen tuen versio, jonka palvelinohjelmistoille on taattu tietoturvapäivitykset vuoteen 2015 saakka)
  2. Avaa pääte ja aja sudo apt-get install php5 php5-mysql mysql-server, mikä asentaa em. ohjelmat ja kaikki niiden riippuvuudet, mukaan lukien Apache-palvelimen:
$ sudo apt-get install php5 php5-mysql mysql-server
Luetaan pakettiluetteloita... Valmis
Muodostetaan riippuvuussuhteiden puu       
Luetaan tilatiedot... Valmis        
Seuraavat ylimääräiset paketit on merkitty asennettaviksi:
 apache2-mpm-prefork apache2-utils apache2.2-bin apache2.2-common
 libapache2-mod-php5 libapr1 libaprutil1 libaprutil1-dbd-sqlite3
 libaprutil1-ldap libdbd-mysql-perl libdbi-perl libhtml-template-perl
 libmysqlclient16 libnet-daemon-perl libplrpc-perl mysql-client-5.1
 mysql-client-core-5.1 mysql-common mysql-server-5.1 mysql-server-core-5.1
 php5-common
Ehdotetut paketit:
 apache2-doc apache2-suexec apache2-suexec-custom php-pear dbishell
 libipc-sharedcache-perl tinyca mailx php5-suhosin
Seuraavat UUDET paketit asennetaan:
 apache2-mpm-prefork apache2-utils apache2.2-bin apache2.2-common
 libapache2-mod-php5 libapr1 libaprutil1 libaprutil1-dbd-sqlite3
 libaprutil1-ldap libdbd-mysql-perl libdbi-perl libhtml-template-perl
 libmysqlclient16 libnet-daemon-perl libplrpc-perl mysql-client-5.1
 mysql-client-core-5.1 mysql-common mysql-server mysql-server-5.1
 mysql-server-core-5.1 php5 php5-common php5-mysql
0 päivitetty, 23 uutta asennusta, 0 poistettavaa ja 3 päivittämätöntä.
Noudettavaa arkistoa 30,0Mt.
Toiminnon jälkeen käytetään 73,9M t lisää levytilaa.
Haluatko jatkaa [K/e]?
  1. Asennusvaiheessa pyydetään asettamaan MySQL:n pääkäyttäjälle (root) salasana. Laita se muistiin.
  2. Tarkista Apachen toimivuus selaimella (http://127.0.0.1/ tai http://localhost/)
  3. Nyt voit laittaa PHP-skriptin kansioon /var/www/. Aja komento sudo nano /var/www/testi.php ja kirjoita tiedoston sisällöksi:
<?php
echo "Testi toimii!";
?>
  1. Tallenna painamalla Ctrl+X ja enter (K=kyllä)
  2. Avaa selaimella http://localhost/testi.php. Jos näet vain tekstin, niin PHP toimii. Jos selain yrittää ladata kokonaisena tiedostona sivun, PHP-skriptiä ei ajettu.

Wordpress

Lisäharjoituksena voit asentaa Wordpressin, joka on PHP:lla ja MySQL:llä toimiva blogiohjelmisto. Aloita komennolla sudo apt-get install wordpress

$ sudo apt-get install wordpress
Luetaan pakettiluetteloita... Valmis
Muodostetaan riippuvuussuhteiden puu       
Luetaan tilatiedot... Valmis        
Seuraavat ylimääräiset paketit on merkitty asennettaviksi:
  javascript-common libjs-cropper libjs-prototype libjs-scriptaculous
  libphp-phpmailer libphp-snoopy libt1-5 php-gettext php5-gd tinymce
  wordpress-l10n wwwconfig-common
Ehdotetut paketit:
  mail-transport-agent curl postgresql-client apache apache-ssl
Seuraavat UUDET paketit asennetaan:
  javascript-common libjs-cropper libjs-prototype libjs-scriptaculous
  libphp-phpmailer libphp-snoopy libt1-5 php-gettext php5-gd tinymce wordpress
  wordpress-l10n wwwconfig-common
0 päivitetty, 13 uutta asennusta, 0 poistettavaa ja 3 päivittämätöntä.
Noudettavaa arkistoa 8 107kt.
Toiminnon jälkeen käytetään 30,4M t lisää levytilaa.
Haluatko jatkaa [K/e]?


LAMPista eteenpäin

LAMP ei tänä päivänä enää edusta parasta mahdollista teknologiaa. Apachen kanssa kilpailee moni uusi paljon nopeampi palvelinohjelmisto (esim. NodeJS ja Nginx), Oracleen haltuun siirtynyt MySQL häviää MariaDB:lle ja PostgreSQL:lle ja ohjelmointikielipuolella on nykyisin suositumpaa käyttää JavaEE:tä, Ruby on Railisia tai Pythonia (esim. Djangon kanssa).

Katso myös

Aiheesta muualla