AMDn/ATIn binääriajureiden asentaminen

Linux.fista
Versio hetkellä 3. joulukuuta 2012 kello 05.19 – tehnyt 213.216.242.7 (keskustelu) (xvba-va uusi linkki google auttoi)
Siirry navigaatioon Siirry hakuun

Tämä artikkeli käsittelee AMD/Atin suljettujen näytönohjainajurien asentamista.

Arch Linux

ATIn Catalyst-ajuripaketti on hiljattain poistettu Arch Linuxin pakettivarastoista johtuen ajurin kehityksen jälkeenjääneisyydestä ja sen kehittäjien yhteistyökyvyttömyydestä [1]. Catalystin voi halutessaan asentaa AURissa tarjottavasta epävirallisesta PKGBUILDista.

Catalystin asennuksen jälkeen on tehtävä Xorg.confiin oikeat asetukset. Jos sinulla on jo toimiva xorg.conf, tee siitä varmuuskopio. Jos xorg.confia ei ole, voit luoda sellaisen komennolla

Xorg --configure

Lisätietoja xorg.confin luomiseen löytyy Arch Linuxin wikistä. Kun sopiva xorg.conf on olemassa, ajetaan ATIn oma asetustyökalu komennolla

aticonfig --initial

Jos asetusten luonti onnistui, voit testata 3D-toimintojen toiminnan komennolla

glxinfo | grep direct

(edellyttää mesa-paketin asentamista).

Arch Linuxin wikissä on laaja ohje koskien ATIn näytönohjaimia.

Debian

Asenna ensin root-oikeuksin aptitudella päätteessä

su
Salasana: xxxx

Headerspaketti esim. 64-bittiseen(32-bittiseen eri komento)

aptitude install linux-headers-2.6.32-5-amd64

Seuraavaksi:

aptitude install xorg fglrx-driver fglrx-control fglrx-source mesa-utils module-assistant

Seuraavaksi kirjoitat päättessä

modprobe -r radeon drm

Sitten siirryt

cd /usr/src 

kansioon ja kirjoitat

m-a prepare
m-a a-i fglrx

Seuraavaksi kirjoitat päätteeseen

aticonfig --initial 

Tämä luo automaattisesti oikeanlaisen xorg.conf tiedoston.

Kaiken teet roottina ja niin, että X-ympäristö ei ole käynnissä. Non-free pakettilähteet täytyy myös olla käytössä.

Voit tarkistaa ohjaimen toimivuuden uudelleenkäynnistyksen jälkeen komennolla (X-ympäristö pitää olla käynnissä):

glxinfo | grep direct

Tulos pitäisi näyttää tältä:

direct rendering: Yes
   GL_EXT_copy_buffer, GL_EXT_copy_texture, GL_EXT_direct_state_access,  

Tämä ohje on johdettu näiltä sivustoilta:

Debian wiki

Tecnowizah -Debian howto ATI drivers

Testattu Debian Squeeze 6.0:lla.



Fedora

Ota käyttöön RPM Fusion -pakettivarasto hakemalla sen asennuspaketit (free ja nonfree) osoitteesta http://rpmfusion.org/Configuration ja asentamalla ne. RPM Fusion sisältää näytönohjainajurien ohella muitakin paketteja, jotka eivät syystä tai toisesta voi olla mukana Fedoran virallisissa pakettivarastoissa.

AMD/Atin ajurit löytyvät RPM Fusionin paketista kmod-fglrx. Lisätietoja pakettien asentamisesta löytyy artikkelista Fedoran paketinhallinta.

Paketin asennuksen jälkeen on hyvä käynnistää kone uudelleen ja ajurien pitäisi toimia. RPM Fusion pyrkii toimimaan yhteistyössä Fedoran virallisten asennuslähteiden kanssa, joten yhteensopivuuden pitäisi olla hyvä.

Gentoo

Gentoon sivuilta löytyy myös ATIn korteille erittäin hyvä opas, mutta englannin kielellä.

http://www.gentoo.org/doc/en/ati-faq.xml

openSUSE

Ubuntu

Ubuntussa suljettujen näytönohjaimen ajureiden asentaminen tapahtuu erillisellä Laiteajurit-työkalulla. Lisätietoja löytyy Ubuntu tutuksi -wikikirjasta.

AMD Catalyst

Uusimpien AMD Catalyst ajurien asennus Ubuntu 12.04 LTS versioon menee seuraavasti. Ladataan binääritiedosto AMD sivulta, josta käännetään deb paketti ja -paketeista asennetaan ajuri. Ennen AMD ajureiden lataamista ja asennusta tarkasta että pakettilähteessä on multiverse hyväksyttynä. Sitten tarvitaan seuraavat paketit että binäärin kääntämisen voi suorittaa

sudo apt-get install build-essential cdbs dh-make dkms execstack dh-modaliases fakeroot

Lisäksi 32-bittiset kirjastot, jos käytyössäsi on 64-bit järjestelmä

sudo apt-get install ia32-libs-multiarch:i386 lib32gcc1 libc6-i386
cd /usr ; sudo ln -svT lib /usr/lib64

Sitten ladataan itse AMD ajureiden asennuspaketti, jossa on sekä 32-bittiset että 64-bittiset ajurit. Voit itse hakea AMD-sivulta tai wget apuna käyttäen

wget http://www2.ati.com/drivers/linux/amd-driver-installer-catalyst-12.10-x86.x86_64.zip

Puretaan zip-tiedosto

unzip amd-driver-installer-catalyst-12.10-x86.x86_64.zip

Binääri muunnetaan deb -muotoon.

sh ./amd-driver-installer-catalyst-12.10-x86.x86_64.run --buildpkg Ubuntu/precise

Sitten juuri luodut deb-paketit asennetaan.

sudo dpkg -i fglrx*.deb

Tehdään asetukset

sudo aticonfig --initial -f

Tai jos käytössäsi on AMD APU, kuten E-450 tai A6 niin seuraava saattaa auttaa

sudo aticonfig --adapter=all --initial

Nyt ajurit on asennettu järjestelmään. Seuraava toimenpide kannattaa tehdä varmuuden vuoksi, joskus harvoin käy niin ettei kaikkia tiedostoja luotu oikeisiin kansiohin. Jos tulee virheilmoitus kaikki on kunnossa

64-bit (AMD64) Ubuntu

sudo cp /usr/lib64/switchlib* /usr/lib64/fglrx/

32-bit (i386) Ubuntu

sudo cp /usr/lib32/switchlib* /usr/lib32/fglrx/

Tämän jälkeen uudelleenkäynnistus ja asennus on valmis.

xvba-va

Tämä on tehty videotoistoa varten, että näytönohjain auttaa videon pyörittämisessä ettei ole pelkästään prosessorin varassa. Tämä vaatii vähintään UVD2 tuen, ja tuki löytyy lähtien AMD HD4000 näytönohjaimista. Tarkasta listasta oma näytönohjaimesi http://en.wikipedia.org/wiki/Unified_Video_Decoder#UVD_enabled_GPUs

sudo apt-get install xvba-va-driver libva-glx1 libva-x11-1 vainfo
vainfo

vainfo pitäisi näyttää seuraavanlaisen tulosteen

     libva: libva version 0.32.0
     Xlib:  extension "XFree86-DRI" missing on display ":0.0".
     libva: va_getDriverName() returns 0
     libva: Trying to open /usr/lib/dri/fglrx_drv_video.so
     libva: va_openDriver() returns 0
     vainfo: VA API version: 0.32
     vainfo: Driver version: Splitted-Desktop Systems XvBA backend for VA-API - 0.7.8
     vainfo: Supported profile and entrypoints
     VAProfileH264High               :	VAEntrypointVLD
     VAProfileVC1Advanced            :	VAEntrypointVLD

Vielä symbolinen linkki ja asennus on valmis.

64-bit:

sudo ln -s /usr/lib/va/drivers/fglrx_drv_video.so /usr/lib/x86_64-linux-gnu/dri/fglrx_drv_video.so

32-bit:

sudo ln -s /usr/lib/va/drivers/fglrx_drv_video.so /usr/lib/dri/fglrx_drv_video.so

Jos käytössäsi on AMD APU E-450 tai A6 esimerkiksi, eikä toimi odotetusti, niin saattaa olla että täytyy käyttää vähän muokattua xvba-video -versiota.Sen voi ladata täältä https://launchpad.net/ubuntu/+source/xvba-video ( Tarkistettu 3.12.2012)

Catalyst -ajurin poistaminen

Avoimen koodin ajureihin voi palata takaisin seuraavilla komennoilla

sudo apt-get remove --purge fglrx fglrx_* fglrx-amdcccle* fglrx-dev*

poista xorg.conf eli vanhat asetukset

sudo rm /etc/X11/xorg.conf

Sitten asennetaan xorg uudelleen ja luodaan uusi xorg.conf

32-bit

sudo apt-get install --reinstall xserver-xorg-core libgl1-mesa-glx libgl1-mesa-dri

tai 64-bit järjestelmä

sudo apt-get install --reinstall libgl1-mesa-glx:i386 libgl1-mesa-glx:amd64 libgl1-mesa-dri:i386 libgl1-mesa-dri:amd64 xserver-xorg-core

Sitteen tehdään uudet xorg-asetukset ja tämän jälkeen käynnistä tietokone uudelleen

sudo dpkg-reconfigure xserver-xorg

Katso myös